Opraviť Error: Vaše PHP installZdá sa, že chýba rozšírenie MySQL, ktoré vyžaduje WordPress

"Vaše PHP installZdá sa, že chýba rozšírenie MySQL, ktoré vyžaduje WordPress„Vyskytla sa chyba mnohých majiteľov blogov a webových stránok WordPress.
To nie je dôvod na obavy. Nedostatok rozšírenia MySQL z PHP je typické pre operačné systémy nainštalované od nuly, VPS alebo dedikovaných serverov, kde rozšírenia PHP neboli súčasťou inštalačného balíka. Tento problém sa vyskytuje na oboch stranách ubuntu a CentOS. V tomto scenári je problém vyriešený veľmi jednoducho pomocou a update PHP a inštalácia modulu "php-mysql".
Update Inštalácia rozšírenia PHP a MySQL na Ubuntu

apt-get update
apt-get install php-mysql

Update Inštalácia rozšírenia PHP a MySQL na CentOS

yum update
yum install php70w-mysql

Po tomto kroku restartmáte službu Apache alebo Nginx.

Narazil som aj na scenár, v ktorom hoci rozšírenie MySQL v PHP existuje, blog bol vytvorený na WordPress zobrazila chyba „Váš PHP installZdá sa, že chýba rozšírenie MySQL, ktoré vyžaduje WordPress“. Vo väčšine prípadov sa chyba vyskytne počas inštalácie WordPress. Tentokrát sa však objavil na blogu, ktorý bol aktívny už niekoľko rokov.
V tejto situácii som zistil, že problém nie je s modulmi PHP, ale s veľmi starou verziou WordPress, ktorý už nie je kompatibilný s PHP 7.4.4RC1. Jednoduchý upgrade WordPress najnovšia verzia chybu opravila.

Vášnivý k technológiám, rád testujem a píšem návody o operačných systémoch macOSlinux, Windows, o WordPress, WooCommerce a konfigurácia webových serverov LEMP (Linux, NGINX, MySQL a PHP). píšem ďalej StealthSettings.com od roku 2006 a o pár rokov neskôr som začal písať na iHowTo.Tips návody a novinky o zariadeniach v ekosystéme Apple: iPhone, iPad, Apple Hodinky, HomePod, iMac, MacBook, AirPods a príslušenstvo.

Pridať komentár