Oprava PROBLÉM: Váš server beží PHP verziu, ale WordPress 5.1.6 3.2.1 5.2.4 vyžaduje najmenej.

Oznámenie pre všetkých, nie je známe, že sa inštalovať alebo robiť upgradeCPC na novšiu verziu 3.2Je nevyhnutné, aby inštalovať novšiu verziu 5.2.4.

Ak je server nainštalovať verziu PHP staršie než 5.2.4 nainštalovať verziu WordPress 3.2.1objavia chyba / Message "Váš server beží PHP verzia 5.1.6 Určené WordPress 3.2.1 ale aspoň 5.2.4".
Problém sa dá vyriešiť veľmi jednoducho upgrade PHP, ale pred tým by mala pár vecí do úvahy. Prvé, upgrade PHP hosting je vylúčený zo zdieľanej, Takže si môžete urobiť upgrade, musia mať administrátorský prístup k serveru (dedikovaný server alebo VPS). V druhej, pred upgradom musí dávať pozor, aby dokument a že Nová verzia PHP nedávať Chyby iné stránky hostované na tomto serveri.

pre OS je najrozšírenejší webové servery (Agreart a / WHM) Vám ukáže, ako sa to robí Upgrade na PHP na CentOS 5.2.10.x 5 32-bit.

Upgrade na PHP 5.1.x 5.2.x na 5-bit CentOS 32.x

1. Skontrolujte, ktoré balíčky / sú inštalované moduly PHP (napr. PHP-mcrypt) okrem štandardného paketu. Ak existujú, budú odstránené alebo actuzlizate.

Skontrolujte inštalované balíky:

rpm-qa | grep php

old_php_version

2. Pridanie nových archívov potrebný upgradePHP verzia acquis.

nano / etc / yum.repos.d / CentOS-Testing.repo

V novo vytvoreného súboru (CentOS-Testing.repo) Bude pridať nižšie uvedené riadky (copy / paste):

[C5 testovanie]
name = 5 CentOS-Testovanie
baseURL = http: //dev.centos.org/centos/$releasever/testing/$basearch/
enabled = 1
gpgcheck = 1
gpgkey = http: //dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X uložte súbor CentOS-Testing.repo.

3. Aktualizácia PHP cez Yum:

aktualizácie yum

4. reštart / httpd :

service httpd restart

Po vykonaní reštartu httpd a skontrolovať inštalované balíky:

new_php_version

Kontrola chýb modules / balíčkov:

php -v

- Upgradovať PHP / 32-bit CentOS (i386).

Oprava PROBLÉM: Váš server beží PHP verziu, ale WordPress 5.1.6 3.2.1 5.2.4 vyžaduje najmenej.

O autorovi

stealth LP

Zakladateľ a editor stealth nastavenieDátum 2006.
Skúsenosti s operačnými systémami Linux (najmä CentOS), Mac OS X, Windows XP> Windows 10 a WordPress (CMS).

Pridať komentár